Набор статей и руководств по дизассемблеру IDA


Требования


Вы должны знать ассемблер процессоров семейства Intel x86. Также, поскольку на сей раз я представляю библиотеку для pluginов к IDA Pro, Вы должны иметь копию этого замечательного дизассемблера (библиотека была написана для версии 3.85b, и, поскольку я не располагаю другими версиями, поддерживающими plugins (такая возможность появилась в версии 3.84), то я не могу гарантировать её работоспособность на других версиях IDA). Если же Вы намерены пользоваться исходным кодом, Вам нужно знать C++ ,и для сборки потребуются Borland C++ 5.02 или Watcom 10, а также IDA SDK для Вашей версии IDA. Также если Вы намерены изменять или расширять характеристики набора инструкций, Вам потребуется Perl. Perl сгодится любой, даже под Unix, если же Вы хотите иметь его персонально на своём персональном компьютере (это всё дурное влияние Билли), могу порекомендовать ActiveState Perl под Win32, взять можно здесь, бесплатно, по крайней мере, когда я ходил туда последний раз за версией 515, было бесплатно...

PS: Не нужно у меня спрашивать, где найти IDA Pro или SDK к ней. Попробуйте посетить сайт автора по адресу www.datarescue.com.




Начало  Назад  Вперед



Книжный магазин